Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

We are excited to announce that a full Forum system upgrade is under way, which will make it even easier to get answers to your questions, help other owners by using your boating experience, and receive dependable advice from our network of experts. While things may look and operate a little differently, we believe the new system will ultimately improve your Forum Member experience.

We are doing everything we can to transition your account smoothly without you having to change your current login, username or password. You should be able to get into your account exactly the same way once the transition takes place. However, if you have any questions or comments, please leave a comment in the General Discussions category.

We look forward to sharing new features with you as we upgrade and improve your Owner's Club Forum experience!

Live well not working

2001 sd237 - sink works - wash off hose works - live well not so much - I am not getting any water to go in.. any suggestions on what to check.

Comments

  • nquirknquirk Posts: 393Member, Moderator ✭✭✭✭

    @melisazack, first place to start is the livewell pump.    This is what it looks like

    image

    It will be located in the bilge area of your boat.  You should have two of these in that location.  One is your bilge pump, the other is the livewell pump.  If you only have one, then you don't have a working livewell.  (Many Hurricanes have the livewell, the switch, but if it wasn't ordered from the factory or retrofit later, the piping and pump won't be present)

    It will have a ballcock valve on it similar looking to this image

    Make sure that is in the open position so it can draw water in from the lake.

    Two, is the pump working when you turn on your master power and the livewell power.  If not you have a power supply or a pump electrical issue.

     

     

    ------------------------------------------------------------------------------
    2010 Hurricane SS 188 OB
    2010 Mercury Optimax 200HP / Mercury SS High Five 19P
    2010 Trailmaster SC trailer
  • Ernest TErnest T Posts: 125Member, Moderator ✭✭✭
    Here is a tip that works on my boat.  Just about every year I turn on the live well pump only to find no water being pumped.  This is because the pump needs to be primed.  After you have confirmed that the pump is indeed running and that the valves mentioned above are open as nquirk has shown, try this:

    In open water, turn on the live well pump and back the boat at a steady speed.  This forces water through the live well intake and will hopefully prime the pump.  It can take a fair amount of time for this to work, but it usually works for me.  Be careful not to get too fast backing, or you will get water coming into the boat over the transom.
    2010 Hurricane 2100 (217) Sun Deck
    2008 Yamaha F150 TXR Outboard
    2008 Yamaha FX **** Cruiser Waverunner
  • cjjjdeckcjjjdeck Posts: 255Member, Moderator ✭✭✭
    You have a 2001, are you the original owner?  Was it working before and just stopped working recently?

    The washdown and galley/head sinks work off a separate pump from the livewell.
    2012 SD237 I/O Mercruiser 5.0L MPI ECT/ Bravo 3
    2012 Load Rite Elite Tandem axle trailer

Sign In or Register to comment.