Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

We are excited to announce that a full Forum system upgrade is under way, which will make it even easier to get answers to your questions, help other owners by using your boating experience, and receive dependable advice from our network of experts. While things may look and operate a little differently, we believe the new system will ultimately improve your Forum Member experience.

We are doing everything we can to transition your account smoothly without you having to change your current login, username or password. You should be able to get into your account exactly the same way once the transition takes place. However, if you have any questions or comments, please leave a comment in the General Discussions category.

We look forward to sharing new features with you as we upgrade and improve your Owner's Club Forum experience!

Losing max RPM

sgceiselsgceisel Member Posts: 5
Have Fundeck GS202 with a Yamaha 2004 F150 XTRC.  Started losing top end speed at WOT.  Sometimes the engine would surge to higher RPM.  It has gradually gotten worse with max RPM about 4600.  Idles fine.  Runs OK at 3600 RPM.  Changed fuel filter (no help), checked spark plugs (no black deposits), pulled fuel injectors (no sediment from small filters), changed primer bulb.  I know there are two more filters but they are difficult to get too and one is internal.   Took it back out and ran with the cowling off to see if the fuel filter maintained a levet.  Watching the level in the fuel filter cup it ran just above the bottom of the visible part of the filter.  I dont think this is normal and I am wondering whether this indicates a bad fuel pump.  Any suggestions on further troubleshooting.?

Comments

  • IdahoMarkIdahoMark Member Posts: 11
    Using Regular or Premium?  If Reg, try a tank of Premium.  I noticed an RPM surge the one time I used Reg.  Returned to Premium and it went away.
  • sgceiselsgceisel Member Posts: 5
    Problem was fouled fuel injectors.
Sign In or Register to comment.