Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

We are excited to announce that a full Forum system upgrade is under way, which will make it even easier to get answers to your questions, help other owners by using your boating experience, and receive dependable advice from our network of experts. While things may look and operate a little differently, we believe the new system will ultimately improve your Forum Member experience.

We are doing everything we can to transition your account smoothly without you having to change your current login, username or password. You should be able to get into your account exactly the same way once the transition takes place. However, if you have any questions or comments, please leave a comment in the General Discussions category.

We look forward to sharing new features with you as we upgrade and improve your Owner's Club Forum experience!

Rectifier & Regulator

BWHBWH Posts: 66Member ✭✭

Was out yesterday and got flashing check engine light.  On off on off sequence of check enginie light.  Looked it up in the Suzuki manual and it indicated it was the "rectifier & regulator (over charging)".  No other symptoms noted while underway.  Tach normal, lights normal motor operation all appeared normal. Motor starts fine today and all systems are operating, but check engine light is still blinking.   Motor is 2006 Suzuki 150 with dual batteries which are about 6 months old.  Anyone have experience with this issue?  Does this require immediate repair?  Suggestions?   BTW, I do not have the experience to do indepth electrical testing.  Thanks in advance!

 

Comments

  • servmgr64servmgr64 Posts: 23Member
    I would suspect you have a defective alternator. As with your car when the check engine light is flashing it is not safe to drive as it could damage another component, I would treat the boat engine the same way and not use it if it is flashing.
    servmgr64 2013 FD226 2013 Mercury 150 4-stroke 2014 Shorelander
  • nquirknquirk Posts: 553Member, Moderator ✭✭✭✭

    @BWH, I'd have the altenator looked at.  The engine check is indicating that it is problematic.  You could check the voltage on your batteries before starting and with the engine running.  If it is overcharging them you'd see a spike in the output in voltage.    Beyond that, you'd need to have the alternator replaced or at minimum serviced.

    From what the manual indicates the regulator which controls the constant voltage load produced is provided excessive charge or voltage to your batteries and electrical system.

    ------------------------------------------------------------------------------
    2010 Hurricane SS 188 OB
    2010 Mercury Optimax 200HP / Mercury SS High Five 19P
    2010 Trailmaster SC trailer
  • BWHBWH Posts: 66Member ✭✭

    On my cars when I get the warning light.  I normally disconnect the battery to determine if it returns; may not be a good move, but si what I alwys do.  After discussing issue with friend, I decided to try this technique with my boat.  Utilized reset on kill switch.  Light went out.  Ran boat two days this weekend and light did not come back on.  Friend suggest that it "may" have been set up as a service alarm.  20 hr service, then 100, then 200.  I was just over 220 when the light came on initially.  May be the wrong approach, but seemed to be worth a try.  Any thoughts or experience with this?

     

         

  • nquirknquirk Posts: 553Member, Moderator ✭✭✭✭
    With or without the alarm, there is still a possibility of having a problem with either the rectifier or regulator.

    The rectifier converts AC to DC to charge your 12V system.  If it isn't working, you're battery will fail to recharge.  If you check it (even monitor the voltage meter on your boat to see if it drops over time)

    The regulator is there to regulate the voltage being provided to the battery.  Under normal circumstances, and outboard system will give you readings between 12.5V to 14.4V.

    Using a voltmeter, test the voltage of the battery at the following times:
    - before starting
    - after starting
    - while running at idle
    - while running at idle with accessories on (nav lights, bilge pump, stereo)
    - (If you have a 2nd person to assist) while running around 2000rpms

    If all of these readings are in the 12.5 to 14.4V range, you should be in good shape.

    If the range is above 14.4V, then your regulator is faulty.  The end result of not repairing it is that it will damage the battery

    Hope this helps clarify what I was getting at before.  Absolute worst case, you have one of these issues, it doesn't charge or damages your battery which in itself isn't a big deal, unless you happen to be several miles from shore.



    ------------------------------------------------------------------------------
    2010 Hurricane SS 188 OB
    2010 Mercury Optimax 200HP / Mercury SS High Five 19P
    2010 Trailmaster SC trailer
  • BWHBWH Posts: 66Member ✭✭
    nquirk, thanks for the response and the info.  I hope to check with a multimeter this weekend.  My dashboard gauge has remained constant around 13 +/-.  Battery seems strong; I have 2 and have been runnig off of only one to ensure I had cranking ability if things went south.  This is what prompted me to give it a go as is.  Although a novice, will def try to check to ensure no additional damage is done. 
Sign In or Register to comment.